WIP: new scanning framework
Holger Schurig
hs4233 at mail.mn-solutions.de
Tue Jun 26 09:14:46 EDT 2007
> > wlan_scan_networks()
>
> Lets rename this to libertas_ instead of wlan_
Sure.
> > for (i=0; i<MAX_RATES; i++) {
> > *tlv = libertas_bg_rates[i];
> > if (*tlv == 0)
> > break;
> > if (*tlv==0x02 || *tlv == 0x04 || *tlv == 0x0b || *tlv ==
> > 0x16) *tlv |= 0x80;
>
> Might want to add a note here ^^^ that the |= 0x80 is because
> the firmware requires basic rates to have the MSB set.
> > // TODO: the txpd is sent to the firmware, but
> > nothing happens
>
> I guess we'll have to check on this with CozyBit and/or
> Marvell.
Yeah, that's the bummer right now. Without it, I'd still be able
to use most of the clearer framework, but need to re-schedule
myself with a workqueue, to scan in pieces. I'd also again need
the "full_scan"-parameter.
> The firmware spec seemed to indicate that we could get away
> with not sending the wake null frame if there was data to
> send, since the PS mode bit in the data frame would be 1
> already and therefore signal to the AP that we are leaving
> power save mode.
Right.
> However, then we have two cases, one where
> there's no data queued and one where there is.
That is simple to test.
Also, I don't need to the send any of those NULL packets if I'm
not connected, which I should test as well.
> All in all, it's a lot cleaner than what's there
Thanks.
More information about the libertas-dev
mailing list